Simple-Scada forum
Simple-Scada 2 => Ваши вопросы => Тема начата: sgikip от 26 Июля 2017, 12:19:16
-
Выскакивают жёлтые восклицательные знаки через каждые 3 мин. пропадает связь между Modbus uneversal server и Simple-Scada 2. В чём проблема? С Simple-Scada 1.3.3 такого не было.
-
Здравствуйте. В журнале сервера скады выводятся какие-то сообщения связанные с OPC сервером?
-
Здравствуйте, в сообщения Master OPC Modbus server на 500 тег, ошибка включения команды 3 в устройстве, и включен тайм-аут ошибки запроса 1. Вот такие сообщения, в строке качество BAD через две три минуты связь восстанавливается что делаю нет так.
-
Здравствуйте, в сообщения Master OPC Modbus server на 500 тег, ошибка включения команды 3 в устройстве, и включен тайм-аут ошибки запроса 1. Вот такие сообщения, в строке качество BAD через две три минуты связь восстанавливается что делаю нет так.
Simple-Scada получает качество тегов и их значения от OPC-сервера. Как Вы описали на OPC-сервере качество у тегов BAD. Именно поэтому в скаде отображаются восклицательные знаки. Нужно искать причину в связи OPC-сервера и контроллера. Возможно нужно как-то изменить конфигурацию OPC-сервера.
С Simple-Scada 1.3.3 такого не было.
Вы можете отключить контроль качества через Options.exe в разделе "Simple-Client --> Контроль качества". Тогда восклицательные знаки не будут отображаться при проблемах связи. Но мы бы рекомендовали не выключать контроль качества, а найти и устранить причину обрывов связи.
-
Контроль качества отключил, но знаки остались, чуть реже но появляются, к Modbus OPC server подключены шесть приборов Овен УКТ 38 по температуре, вроде настройки в Modbus правильные, хотя контроллеры Simens работают нормально без потери связи.
-
Контроль качества отключил, но знаки остались, чуть реже но появляются
Странно, они не должны появляться с отключенной опцией. Может быть Вы отключили данную опцию на серверном компьютере, а на клиентском она включена?
хотя контроллеры Simens работают нормально без потери связи.
Здесь причина скорее всего не в контроллерах, а в связи между OPC-сервером и контроллерами.
-
Кстати, все хотел спросить, но постоянно забываю. Одной из вирт. машин выделено 4 ядра. Лектус иногда загоняется до 25% (забивает поток), при этом сервер 2230 начинает потреблять 0.1% и "подвисает", пока не снимешь задачу лектуса. Может ли быть такое, что лектус запущенный сервером скады висит в том-же потоке (или что там у вас с виртуализацией) и они просто не могут более 1 ядра на двоих пользовать?
-
Может ли быть такое, что лектус запущенный сервером скады висит в том-же потоке (или что там у вас с виртуализацией) и они просто не могут более 1 ядра на двоих пользовать?
Да, такое может быть. Операционная система при необходимости распределяет потоки приложений по ядрам. Simple-Scada 2 выполняет в отдельных потоках архивацию и работу с БД, работу с OPC-серверами, работу с системой отчетов, отправку sms/e-mail сообщений и т.п. задачи. В случае загрузки основного ядра ОС может передать эти потоки на обработку другим ядрам. Но основной поток сервера, как и любого другого приложения будет на 1 ядре и могут возникнуть проблемы если он полностью загружен.